Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17

Thread: lost connection with server

  1. #11
    Mayor
    Join Date
    Oct 2013
    Posts
    1,275
    World
    Ares
    Maintenance. It is now after 21 o'clock.

  2. #12
    Administrator BB_Odhran's Avatar
    Join Date
    Oct 2017
    Posts
    1,097
    World
    Zeus
    Quote Originally Posted by NoEyedDeer View Post
    Cannot connect. Was strolling around my island looking for stuff and got disconnected, now won't reconnect.
    I know there is maintenance today, but my calculations show it does not start for a few hours.
    Is any else having issues connecting to the game?
    Are you still experiencing this issue?

    -BB_Odhran

  3. #13
    Recruit Inearlon's Avatar
    Join Date
    May 2012
    Location
    Beautiful England
    Posts
    3
    World
    Zeus
    Dreadful problems trying to connect over the last few days...tried the previous workaround etc with no joy. Becoming disheartened as when I do get in ( rarely ) island is a mess and events pointless as missed the opportunity to participate. I am in the UK and usually try logging in between 18.00 and 22.00 gmt. Keep trying but really annoying now

  4. #14
    Recruit
    Join Date
    Apr 2015
    Location
    South Africa
    Posts
    6
    World
    Zeus
    Could not get on for about a week. Rotten login procedure compliments of BB and Ubisoft. Hell been trying all day to get on to dismantle my island and dish out what I can. 13 hours and 31 minutes - no luck
    No there is nothing wrong with my Internet connection

  5. #15
    Recruit
    Join Date
    Jan 2019
    Posts
    1
    World
    Zeus
    Unable to login today. Keep getting stuck with “Lost connection to server”. I am unable to login to the US server (Zeus Realm 1) or German Server (Funkleberg Welt 8) with account name xaoslau used for both. I have tried multiple times and it switches to “Lost connection to server” before completing the login and putting me on the main island. As today is not scheduled maintenance, what is going on?

  6. #16
    Recruit
    Join Date
    Nov 2017
    Posts
    12
    World
    Zeus
    12:17 pm 7/17/2019 same thing still , log in, game starts to load "connection to server has been lost" Btw, sorry if I posted in wrong section . Guess I wasn't LOOKING in the correct section either
    4:56 pm 7/17/2019 still the same

  7. #17
    Recruit
    Join Date
    Nov 2017
    Posts
    12
    World
    Zeus
    I am still having this issue at 4:57 pm pacific time , I see here on the forums ,some have been having this issue off and on for a while [week or better] it started for me some time today. I was on yesterday sometime in afternoon [7/16/2019] all was fine . Didn't want to loose my daily log in :/ so much for THAT ,lololol. It's not my computer or anything , other browser game I play is working fine , Far Cry 5 is working fine, etc etc

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts