Reply to Thread
Results 1 to 6 of 6

Thread: lost connection with server

  1. #1
    Recruit
    Join Date
    Nov 2017
    Posts
    4
    World
    Zeus

    lost connection with server

    I was doing my maps a few hours and the game kicked me. When I tried to refresh the game it loaded most of the way , then I got a message saying server connection lost please wait while we try to resolve the issue ............then a refresh tab appears , but when i try to refresh, it just does the same thing . I am wondering , before I spend any more time trying to "resolve " the issue myself, if it just me , or are others having the same issue ? thank you for your time in reply

  2. #2
    Settler
    Join Date
    Dec 2016
    Posts
    117
    World
    Zeus
    I lost connection to forum when I tried to open this thread. Coincidence? I think not!

  3. #3
    Administrator BB_Odhran's Avatar
    Join Date
    Oct 2017
    Posts
    406
    World
    Zeus
    Are you still having issues with staying connected when attempting to log in?

    -BB_Odhran

  4. #4
    Soldier
    Join Date
    Jul 2012
    Location
    Wisconsin
    Posts
    64
    World
    Zeus
    yes can not get on the game

  5. #5
    Mayor
    Join Date
    Oct 2013
    Posts
    1,010
    World
    Ares
    Took me about 20 minutes to get on earlier, but seems to be okay now.

  6. #6
    Administrator BB_Odhran's Avatar
    Join Date
    Oct 2017
    Posts
    406
    World
    Zeus
    Sorry for the issues. Please do let me know if they continue!

    -BB_Odhran

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts