Reply to Thread
Results 1 to 4 of 4

Thread: crashes/unable to load/ loading screen

  1. #1
    Settler
    Join Date
    Nov 2012
    Posts
    109
    World
    Zeus

    crashes/unable to load/ loading screen

    Ok...Going to vent. The past three months….most especially the past three weeks have been horrible. Server crashes, unable to log in, loading screen taking forever. This is getting annoying. Is it really that difficult to stabilize the game? This just seems to be an ongoing problem that is getting worse and worse. I am OK with the time it takes to do things ingame, but when start/stop times, rebuffs, adventures/quests are all affected by an on going issue/s, it gets old real fast. Cache, browser history have all been cleaned, computer restarted.... Hell, just getting to the Forum section took almost an hour.

  2. #2
    Mayor Perwyn's Avatar
    Join Date
    Feb 2012
    Location
    The Shire
    Posts
    1,395
    World
    Zeus
    Yeah, the time it takes to get into the game can be pretty distressing. Add a flash crash into the mix once a day or so, mix gently and now you've got full blown PO'd. Not sure what the issue is with it taking 3,4 & 5 minutes to get past the guy with the sledgehammer but I'm sure hoping the fix is a priority.
    "Very little is needed to make a happy life; it is all within yourself, in your way of thinking." ~ Marcus Aurelius

  3. #3
    Settler
    Join Date
    Dec 2016
    Posts
    238
    World
    Zeus
    try restarting your internet connection thingy too
    Mad scientist.

  4. #4
    Administrator BB_Odhran's Avatar
    Join Date
    Oct 2017
    Posts
    1,097
    World
    Zeus
    Quote Originally Posted by Beel78 View Post
    Ok...Going to vent. The past three months….most especially the past three weeks have been horrible. Server crashes, unable to log in, loading screen taking forever. This is getting annoying. Is it really that difficult to stabilize the game? This just seems to be an ongoing problem that is getting worse and worse. I am OK with the time it takes to do things ingame, but when start/stop times, rebuffs, adventures/quests are all affected by an on going issue/s, it gets old real fast. Cache, browser history have all been cleaned, computer restarted.... Hell, just getting to the Forum section took almost an hour.
    What browser are you using when you are facing these issues? Also as someone else mentioned, have you tried resetting your internet connection? It should not take long at all to load the forum.

    -BB_Odhran

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts