Reply to Thread
Results 1 to 4 of 4

Thread: Storm Recovery - Reconstruction (building created do not seem to count)

  1. #1
    Settler
    Join Date
    Aug 2012
    Posts
    170
    World
    Zeus

    Angry Storm Recovery - Reconstruction (building created do not seem to count)

    You can clearly see I did build 2 Tavern but the Reconstruction quest stay to 0



    https://pasteboard.co/4DNFpue3HQHC.png
    https://i.postimg.cc/4ycwpVCL/Storm-Recovery-Issue.png

    You can clearly see I did build ALL of the appropriate buildings but again everything stay to 0



    https://pasteboard.co/rWstAZOIb6yV.png
    https://i.postimg.cc/X7Ms4HFT/Storm-Recovery-Issue2.png

  2. #2
    Noble Droidhak's Avatar
    Join Date
    Jan 2015
    Posts
    285
    World
    Ares
    Have you left the adventure and come back in? The game has been glitchy when registering quests being completed, but leaving an adventure/home island and coming back usually fixes it.

  3. #3
    Settler
    Join Date
    Aug 2012
    Posts
    170
    World
    Zeus
    yes did all that reload, logoff different web browser nada..
    Only fix was to re-run this ugly scenario.. I ran it the same way I always do and it registered..

    who knows what new bugs is out there but there is clearly issues with this scenario.

    like russian roulette.. you never know when **** will hit.

  4. #4
    Mayor
    Join Date
    Jul 2013
    Location
    ontario, canada
    Posts
    1,235
    World
    Ares
    just did a slow run thru and it worked.. i was worried it wouldn't cause it picked decomposer early on me.
    i did the wiki and place the school 1st.

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts